The ICA browser did not return any server names

Issue : You are trying to connect to a published app from a client and the ICA browser did not return any server names. This issue exists for all versions of citrix presentation server / xenapp and all citrix client versions.



Resolution : The first thing you need to do is locate what browser server / ip address you entered to get the information of the published app. Now from the client machine try to ping the browser server. If you can not ping the browser server is it down?? Is there a firewall between you and the server?

Is the IMA service running on the citrix server you are trying to connect to? Log on to the citrix server you are trying to connect to via RDP or on the console, Now look in the services (Start > Run > services.msc) and make sure the IMA service is started.

Is firewall port 1606 and 1494 open between the client and the citrix server?? Port 1606 is used by citrix to connect to the IMA servcie that runs on the local citrix server. The IMA service will have all the information about the citrix farm including a list of server names.

Try rebooting the server, If there are no users on a server there could be a problem with the IMA service, Reboot the server which will then stop and start the service.

Are you trying to connect to a citrix servers externals IP? If yes have you run the “Altaddr /set %IP ADDRESS%” command on the citrix server? Test connectivity by typing the following at the command prompt telnet %SERVERS IP% 1494 if the dos screen goes black connectivity is fine. If it times out and says can not connect to server there must be a problem with the NAT / Networking
The ICA browser did not return any server names The ICA browser did not return any server names Reviewed by Citrix Tips on 12:31 Rating: 5